We are currently experiencing slower response times across several services.

Incident Report for WeGuard

Resolved

This incident has been resolved.
Posted Mar 16, 2025 - 08:31 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 16, 2025 - 07:07 UTC

Investigating

We are currently experiencing slower response times across several services.
Posted Mar 16, 2025 - 05:49 UTC
This incident affected: APIs and Management Portal.