Google Zero-touch: Issue with enrolling devices on zero-touch - 25th April 2023
Incident Report for WeGuard
Resolved
This incident has been resolved.
Posted Apr 25, 2023 - 18:02 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 25, 2023 - 14:35 UTC
Monitoring
From Google: We have had reports that customers are having trouble enrolling their devices on zero-touch. The screen prompts “Can’t finish Setup Zero-touch enrollment isn’t available. Check your internet connection and try again”. The error is noticed even if you are connected on mobile data or wifi.

Our engineers are investigating the issue and we will post updates here as we have them.
Posted Apr 25, 2023 - 14:30 UTC
This incident affected: Enrollment - Google Android Zero-touch.