A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2025 - 07:11 UTC
Investigating
We are currently experiencing slower response times across several services.. Our engineering team is actively investigating the issue and working on a resolution.
Posted Mar 11, 2025 - 04:49 UTC
This incident affected: APIs and Management Portal.